Back to overview
Resolved
Request disruption
May 8, 2026 at 3:05am UTC
Affected services
Application
Public Assets
Resolved
May 8, 2026 at 3:05am UTC
Our hosting provider AWS is currently experiencing an impact to there data center where our service is running. It appears to be impacting a small number of requests to our servers and you may encounter some errors when using Chameleon. We are monitoring for availability and will keep you informed.
Update 1:
All services seem to be back to normal. We will continue to monitor
Affected services